Items related to MPLS RFCs (Big Books)

MPLS RFCs (Big Books) - Softcover

Loshin, Pete

 
9780124558533: MPLS RFCs (Big Books)

Synopsis

Multiprotocol Label Switching (MPLS) is an important mechanism for switching various networking protocols, including the Internet Protocol, across Asynchronous Transfer Mode (ATM) networks. MPLS has evolved from various proprietary protocols, and today has become a true worldwide standard that continues to grow and change with the development of ATM and related Internetworking technologies.
Volume one of the Big Book of MPLS RFCs collects the bulk of published IETF documents relating to MPLS and its predecessor protocols, providing the engineers who build high-speed, high-performance networks and backbones with the most current information available. Subsequent volumes will be devoted to future MPLS RFCs, many of which are already in progress. This book begins with an incisive introduction to Multiprotocol Label Switching, including a look at its likely future directions, as suggested by the most recent efforts of the IETF MPLS working group. The RFCs are followed by an extensive index that lets readers pursue specific topics and terms across multiple documents.

"synopsis" may belong to another edition of this title.

About the Author

Pete Loshin writes and consults about Internet protocols and open source network technologies. Formerly on staff at BYTE Magazine, Information Security Magazine and other publications, his work appears regularly in leading trade publications and websites including CPU, Computerworld, PC Magazine, EarthWeb, Internet.com, and CNN. Pete Loshin, Independent Consultant

From the Back Cover


Multiprotocol Label Switching (MPLS) is the single most important new technology for Internet routing to emerge in the past few years. When deployed over IP backbones, MPLS makes possible both efficient routing and virtual private networks while improving performance and traffic management.


MPLS is still a work in progress, but this volume contains the latest RFCs that describe MPLS and how it is used; also contained here are the foundational documents that will give you the background necessary to understand both how MPLS works, and why it is needed.


In addition to understanding MPLS itself, you will understand how it has changed over the years (since the earliest label switching proposals were first implemented and documented within the IETF by Cisco and Toshiba); how IP and ATM interact; and why MPLS helps ease the interaction. Also included are RFCs describing the Differentiated Services (DIFFSERV) and Integrated Services (INTSERV) models, and how MPLS works within those models.


Topics covered in this volume include:

  • Requirements for Traffic Engineering over MPLS (RFC 2702)
  • BGP/MPLS VPNS (RFC 2547)
  • NBMA Next Hop Resolution Protocol (NHRP)
  • Classical IP and ARP over ATM (RFC 2225)
  • Multiprotocol Encapsulation over ATM Adaptation Layer 5 (RFC 2684)
  • A Core MPLS IP VPN Architecture (RFC 2917)


And much more. If you buy only one reference on MPLS, this is the one to choose. Written by members of the Internet Engineering Task Force (IETF), this compilation is a complete and authoritative reference on MPLS.

"About this title" may belong to another edition of this title.