Solving Identity Management in Modern Applications : Demystifying Oauth 2.0, Openid Connect, and Saml 2.0
Language: English
Published by Apress, 2022
- Softcover
- New

Seller: GreatBookPricesUK, Woodford Green, United KingdomGreatBookPricesUK
AbeBooks seller since January 28, 2020
Condition: New
US$ 61.84
Quantity: Over 20 available
Add to basketSeller Inventory # 44513444-n
- Title
- Solving Identity Management in Modern Applications : Demystifying Oauth 2.0, Openid Connect, and Saml 2.0
- Author
- Wilson, Yvonne; Hingnikar, Abhishek
- Publisher
- Apress
- Publication year
- 2022
- Condition
- New
- Binding
- Soft cover
- Language
- English
- ISBN 10
- 1484282604
- ISBN 13
- 9781484282601
- Edition
- 2nd Edition
Know how to design and use identity management to protect your application and the data it manages.
At a time when security breaches result in increasingly onerous penalties, it is paramount that application developers and owners understand identity management and the value it provides when building applications. This book takes you from account provisioning to authentication to authorization, and covers troubleshooting and common problems to avoid. The authors include predictions about why this will be even more important in the future. Application best practices with coding samples are provided.
Solving Identity and Access Management in Modern Applications gives you what you need to design identity and access management for your applications and to describe it to stakeholders with confidence. You will be able to explain account creation, session and access management, account termination, and more.
This revised and expanded edition includes additional content providing an overview of the new version of OAuth (2.1)―what led to it, and primary changes in this version (including features removed from 2.1 that were in 2.0 and why they were removed)―as well as coverage of newer specification documents (RFC 8639―Device flow, useful for IoT devices, RFC 8705―mutual Transport Layer Security, RFC 8707―the protocol “resource” parameter, it’s purpose and use, and more).
What You’ll Learn
- Understand key identity management concepts
- Incorporate essential design principles
- Design authentication and access control for a modern application
- Know the identity management frameworks and protocols used today (OIDC/OAuth 2.0/2.1, SAML 2.0)
- Review historical failures and know how to avoid them
Who This Book Is For
Developers, enterprise or application architects, business application or product owners, and anyone involved in an application's identity management solution
"Synopsis" may belong to another edition of this title.
About the Author
Yvonne Wilson is co-founder and Chief Strategy Officer for XploitDefense. She has had many roles in the software industry related to security and identity management as a security and identity architect; enterprise architect; director of developer success working with identity customers; sr. director of security governance, risk, and compliance (GRC); Chief Strategy Officer; and founder of cloud identity services. Yvonne was responsible for IT security strategy and architecture at Sun Microsystems, founded and designed the identity management services offered through Oracle Managed Cloud Services, created a GRC team at Auth0 and founded a world-wide developer success team for Auth0, working with customers and overseeing the creation of an identity management training program for customer-facing support and professional services engineers. Yvonne is currently Chief Strategy Officer at XploitDefense.
In working with business teams at Sun, designing and deploying identity systems for customers at Oracle, and while founding a developer success team at Auth0, Yvonne had the opportunity of working with many customers, from small startups to large enterprises. Her experience spans the implementation of SSO, identity federation, directory services, adaptive knowledge-based authentication, and identity provisioning as well as multilevel authentication systems with certificate-based authentication. She has worked with OIDC, SAML 2.0, WS-Fed, OAuth2.0/2.1, and OpenID. From this depth of experience, Yvonne realized the growing need for a basic overview of identity management concepts that is understandable to business application owners as well as architects and developers.Abhishek Hingnikar is at Okta, the identity provider for the internet. He has several years of experience designing and demonstrating Identity Management solutions to customers using Auth0 using OAuth 2.0/2.1, OpenID Connect and SAML 2.0. His current focus areas involve Consumer IoT, Device Based Identity and designing solutions that explore web based identity in peripheral domains.
"About the title" may belong to another edition of this title.
GreatBookPricesUK
Woodford Green, United Kingdom
AbeBooks seller since January 28, 2020
Shipping rates from United Kingdom to U.S.A.
| Item | 10 to 27 business days | 10 to 30 business days |
|---|---|---|
| First item | US$ 19.82 | US$ 19.82 |
Payment methods
Store description
GreatBookPrices.com is your top source for finding new books at the absolute lowest prices, guaranteed ! We offer big discounts - everyday - on millions of titles in virtually any category, from Architecture to Zoology -- and everything in between. Discover great deals and super-savings, on professional books, text book titles, the newest computer guides, or your favorite fiction authors. You'll find it all - at HUGE SAVINGS - at GreatBookPrices. Browse through our complete online product catalog today. Serving customers around the world for years, we help thousands find just the books they're looking for -- at incredibly low, bargain prices.…
Specialty
TradeBooksSeller's business information
Far Corner Europe Limited
19-20 Bourne Court, 19-20 Bourne Court
Woodford Green, United Kingdom IG8 8HD
Terms of sale
Company Name: GreatBookPricesUK
Legal Entity: Far Corner Europe Limited
Address: 19-20 Bourne Court, Southend Road, Woodford Green Essex, UK IG8 8HD
Registration #: 10691061
Authorized representative: Danielle Hainsey
Shipping terms
Our warehouses across the globe are fully operational without substantial delays. We are working hard and continue to overcome the daily challenges presented by COVID-19. There have been reports that delivery carriers are experiencing large delays resulting in longer than normal deliveries to customers. See USPS's website for further detail. We would like to apologize in advance if your item arrives later than the expected delivery due date.
Internal processing of your order will take about 1-2 business days. Please allow an additional 4-14 business days for Media Mail delivery. We have multiple ship-from locations - MD,IL,NJ,UK,IN,NV,TN & GA