Solving Identity Management in Modern Applications: Demystifying OAuth 2, OpenID Connect, and SAML 2
Language: English
Published by Apress, 2022
- Softcover
- New

Seller: Ria Christie Collections, Uxbridge, United KingdomRia Christie Collections
AbeBooks seller since March 25, 2015
Condition: New
US$ 74.23
Quantity: Over 20 available
Add to basketItem description from seller
In English.
Seller Inventory # ria9781484282601_new
- Title
- Solving Identity Management in Modern Applications: Demystifying OAuth 2, OpenID Connect, and SAML 2
- Author
- Wilson, Yvonne; Hingnikar, Abhishek
- Publisher
- Apress
- Publication year
- 2022
- Condition
- New
- Binding
- Soft cover
- Language
- English
- ISBN 10
- 1484282604
- ISBN 13
- 9781484282601
- Edition
- 2nd Edition
- Item weight
- 894 grams
Know how to design and use identity management to protect your application and the data it manages.
At a time when security breaches result in increasingly onerous penalties, it is paramount that application developers and owners understand identity management and the value it provides when building applications. This book takes you from account provisioning to authentication to authorization, and covers troubleshooting and common problems to avoid. The authors include predictions about why this will be even more important in the future. Application best practices with coding samples are provided.
Solving Identity and Access Management in Modern Applications gives you what you need to design identity and access management for your applications and to describe it to stakeholders with confidence. You will be able to explain account creation, session and access management, account termination, and more.
This revised and expanded edition includes additional content providing an overview of the new version of OAuth (2.1)―what led to it, and primary changes in this version (including features removed from 2.1 that were in 2.0 and why they were removed)―as well as coverage of newer specification documents (RFC 8639―Device flow, useful for IoT devices, RFC 8705―mutual Transport Layer Security, RFC 8707―the protocol “resource” parameter, it’s purpose and use, and more).
What You’ll Learn
- Understand key identity management concepts
- Incorporate essential design principles
- Design authentication and access control for a modern application
- Know the identity management frameworks and protocols used today (OIDC/OAuth 2.0/2.1, SAML 2.0)
- Review historical failures and know how to avoid them
Who This Book Is For
Developers, enterprise or application architects, business application or product owners, and anyone involved in an application's identity management solution
"Synopsis" may belong to another edition of this title.
About the Author
Yvonne Wilson is co-founder and Chief Strategy Officer for XploitDefense. She has had many roles in the software industry related to security and identity management as a security and identity architect; enterprise architect; director of developer success working with identity customers; sr. director of security governance, risk, and compliance (GRC); Chief Strategy Officer; and founder of cloud identity services. Yvonne was responsible for IT security strategy and architecture at Sun Microsystems, founded and designed the identity management services offered through Oracle Managed Cloud Services, created a GRC team at Auth0 and founded a world-wide developer success team for Auth0, working with customers and overseeing the creation of an identity management training program for customer-facing support and professional services engineers. Yvonne is currently Chief Strategy Officer at XploitDefense.
In working with business teams at Sun, designing and deploying identity systems for customers at Oracle, and while founding a developer success team at Auth0, Yvonne had the opportunity of working with many customers, from small startups to large enterprises. Her experience spans the implementation of SSO, identity federation, directory services, adaptive knowledge-based authentication, and identity provisioning as well as multilevel authentication systems with certificate-based authentication. She has worked with OIDC, SAML 2.0, WS-Fed, OAuth2.0/2.1, and OpenID. From this depth of experience, Yvonne realized the growing need for a basic overview of identity management concepts that is understandable to business application owners as well as architects and developers.Abhishek Hingnikar is at Okta, the identity provider for the internet. He has several years of experience designing and demonstrating Identity Management solutions to customers using Auth0 using OAuth 2.0/2.1, OpenID Connect and SAML 2.0. His current focus areas involve Consumer IoT, Device Based Identity and designing solutions that explore web based identity in peripheral domains.
"About the title" may belong to another edition of this title.
Ria Christie Collections
Uxbridge, United Kingdom
AbeBooks seller since March 25, 2015
Shipping rates from United Kingdom to U.S.A.
| Item | 6 to 12 business days | 6 to 12 business days |
|---|---|---|
| First item | US$ 16.95 | US$ 16.95 |
Payment methods
Store description
Hello! Ria Christie Collections is an online venture that was initially set up in 2012 to sell books. We do not have a physical high street store. We are professional online booksellers. We only sell brand new books in perfect condition that we source from various suppliers and the publishers. Primarily, our aim is to provide an excellent service to all our customers. We always work as a team to achieve this. Our other objectives are to: 1. Ensure that all our products reach their destination quickly in a safe and secure manner 2. Answer to all our customer queries within 24 hours 3. Ensure that our customers are happy with their purchases 4. Provide all the items at a competitive price 5. Always listen to our customers Ria Christie Collections is not a registered company. It is a Sole Trader venture. Other key information is shown below: Contact Person Name: Rakesh Luchmun (Mr) Storefront Name: Ria Christie Collections Place of Establishment Address: Suite B; ARUN House; ARUN Building Arundel Road Uxbridge UB8 2RR United Kingdom E-Mail Address: riachristie@hotmail.co.uk VAT Number: GB 160 5650 25 We always work hard and aim to comply with all of Abebooks Policies. If you have any issues, please do not hesitate to write to us whether before or after a purchase. We promise to reply to you promptly and, in any case, within 24 hours. Thank you kindly! Yours sincerely Mr Rakesh Luchmun (Founder) and the Ria Christie Collections Team…
Specialty
Educational books, Textbooks, Fiction, Non- fictionSeller's business information
Ryefield Investments Limited
175 Pield Heath Road
Uxbridge, United Kingdom UB8 3NL
Terms of sale
All Returns and Refund are as per Abebooks policies.
Shipping terms
Orders usually ship within 2 business days. If your book order is heavy or oversized, we may contact you to let you know extra shipping is required. Thank you!